WordPress 4.0及以前的老版本将停止安全更新

张子凡 WordPress优化 2022-09-12 15:12:44 阅读(...) 评论(0)

WordPress 官方在 9 月 7 日宣布,自 2022 年 12 月 1 日起,WordPress 安全团队将在三个月内停止为 WordPress 版本 3.7 – 4.0 提供更新。官方 WordPress 仅提供对最新版本软件的支持。安全团队历来有一种向后移植安全修复程序的做法,作为对旧版本网站的礼貌,期望这些网站会自动更新。

WordPress security 安全

到目前为止,这些礼貌的向后移植包括所有支持自动更新的 WordPress 版本。WordPress 3.7 – 4.0 版本已达到使用水平,即不到总安装量的 1%,提供这些更新的好处超过了所涉及的工作量。

为什么停止安全更新

运行 WordPress 3.7 – 4.0 的站点在 WordPress 总安装量中所占的比例非常低。相反,将安全更新向后移植到旧版本的 WordPress 需要大量时间;这种效果随着每个新的主要版本的发布而复合。

这种不平衡的影响意味着安全团队花费大部分时间为绝大多数 WordPress 安装准备反向移植。通过放弃对这些旧版本的支持,新版本的 WordPress 将变得更加安全,因为可以有更多时间专注于他们的需求。

如何过渡这个时期

edited-insecure-version-notice

WordPress 的过时版本(在本例中为 4.0.* 及更早版本)将在仪表板中显示不可关闭的通知,通知用户有可用更新。在这些 WordPress 版本的最终更新中,这些通知将更加突出,并通知管理员他们的 WordPress 版本不再接收安全更新。

更多关于WordPress优化及疑问可以添加QQ群:255308000

除非注明,否则均为泪雪博客原创文章,禁止任何形式转载

本文链接:https://zhangzifan.com/dropping-security-updates-for-wordpress-4.html

发表评论