作为一个非专业 PHP 开发人员,很多时候并没有非常刻意的去了解 PHP 各个版本间的不同区别,所以很多时候在兼容性方面容易出现问题,当然不可否认包括其中子凡开发的一些插件,因为真的还有很多的服务商提供的虚拟主机默认的 PHP 版本都在 PHP5.4 以下,这就导致版本真的太古老而可能存在兼容问题。

PHP

所以就在昨天子凡就遇到了一个 Fanly XZH 熊掌号改造插件的用户说插件无法启用,并且提示“Parse error: syntax error, unexpected '[' in”的致命错误信息,其实问题很简单,是因为最新版的 WordPress 熊掌号改造插件支持了百度搜索落地页时间因子规范,所以在开发的时候果断没有考虑太多,毕竟子凡是一个追求极致,非常受不了代码冗余,所以就没有考虑到兼容 PHP5.4 以前的版本。

出现类似“Parse error: syntax error, unexpected '[' in”的错误,其实是因为从 PHP 5.4 开始,可以直接对函数或方法调用的结果进行数组解引用,在这之前的版本则只能使用临时变量。所以就导致在获取时间因子参数的时候直接使用[0]来获取数组,并没有通过零食变量作为转换。

解决办法其实就非常简单了,直接举个例子:

1
2
3
4
5
6
//代码示例:输出第一篇文章的时间
echo query_posts(array('ignore_sticky_posts'=>1,'orderby'=>'date','showposts' => 1))[0]->post_date;
 
//兼容 PHP5.4 以前的版本,使用临时变量
$jqs = query_posts(array('ignore_sticky_posts'=>1,'orderby'=>'date','showposts' => 1));
echo $jqs[0]->post_date;

当然以上是从代码的兼容性来处理这个问题,如果你的程序拥有大量这样的兼容性情况,修改和操作就显得非常麻烦了,那么子凡觉得最直接最简单的处理方法就是升级 PHP 版本到 5.4 版本及以上,一般的虚拟主机服务商都是提供多个 PHP 版本可供切换的,而如果是自己的独立服务器,安装或升级 PHP 版本即可解决该问题。

其实类似的 PHP 错误问题还有很多,这里子凡只是指出了因为数组解析的问题,所以大家遇到了可以百度一下,哈哈哈!

除非注明,否则均为泪雪博客原创文章,转载请以链接形式标明本文地址

本文链接:https://zhangzifan.com/parse-error-syntax-error-unexpected.html

发表评论