去年开始由于 WordPress 被国内流量攻击,最后的情况就是导致大陆用户访问 WordPress 官方或者升级更新 WordPress 程序时就会出现 429 Too Many Requests 的错误提示,从而无法正常的升级 WordPress 程序,而最近 WordPress 5.4 版本发布,又开始有一波人开始慌乱了,于是子凡才想起一个插件:WP-China-Yes

WordPress 429 Too Many Requests

首先非常感谢 WP-China-Yes 插件的作者能够提供一个这样的插件,并且还曾经特地跑到泪雪博客在留言告知子凡,由于当时一忙就忘记了这回事,因为自己平时通过一些香港或者国外服务器来解决更新和访问 WordPress,一时间忘记给泪雪博客的 WordPress 朋友们提供解决办法,所以现在来啦。

WP-China-Yes 插件的介绍和由来

因为 WordPress 官方的服务器都在国外,所以中国大陆的用户在访问由 WordPress 官方提供的服务(插件、主题商城,WP 程序版本更新等)时总是很缓慢。

近期又因为被攻击的原因,WordPress 的 CDN 提供商屏蔽了中国大陆的流量,导致大陆用户访问插件主题商城等服务时报 429 错误。

为解决上述问题,开发了 WP-China-Yes 插件,该插件可以将 WP 站点访问官方服务的一切流量迁移到由社区志愿者维护的大陆源上,从而全面优化用户体验。

WP-China-Yes 插件的使用方法

GitHubhttps://github.com/sunxiyuan/wp-china-yes

插件作者官方https://www.ibadboy.net/archives/3204.html

如果服务器网络不错的可以直接 WordPress 后台“插件”菜单中搜索:WP-China-Yes

下载并安装插件后直接启用即可,该插件会自动接管所有 WP 访问境外服务器的流量。插件不会更改你的 WordPress 程序,若不想使用大陆加速节点,直接停用插件即可。

重要说明:无论你采用何种方式安装插件,都请一定保证插件的目录名是 wp-china-yes,否则插件将无法正常工作。

写在最后

插件无疑是帮助普通 WordPress 用来来解决和实现功能的最简单的方式之一,不用找代理或者找其它办法去下载,当然对于 WP-China-Yes 插件这样的公益项目来说,是需要有服务器做反向代理和节点的支持才能够提供良好的使用保障。

如果你觉得装插件还是很麻烦,那么你还可以加入到子凡的 WordPress 交流群,通过群共享下载到最新版本的 WordPress 文件,如果没有你想要的版本,可以找群主也就是子凡我来亲自帮忙啦!毕竟子凡我是一个 WordPress 的资深爱好者,更愿意和帮助到国内 WordPress 站点更好的发展运营。

更多关于 WordPress 优化及疑问可以添加 QQ 群:255308000

除非注明,否则均为泪雪博客原创文章,禁止任何形式转载

本文链接:https://zhangzifan.com/wp-china-yes.html

发表评论

  1. 明月登楼
    1楼
    明月登楼 2周前 (05-13)

    有了这个插件至少 WordPress 后台更新时没有问题了!流畅了很多!

    • 张子凡
      回复
      张子凡 2周前 (05-14)
      回复 @明月登楼 :前些日子感觉WordPress能直接访问了,但是后来好像又出问题了,不过有梯子就不怕。
  2. 赚钱网
    2楼
    赚钱网 3周前 (05-08)

    文章不错,顶一下

  3. 天云复盘
    3楼
    天云复盘 4周前 (04-30)

    这插件已经给下架了。想想WP官方真恶心,弄这么一出,恶心了国内这么多用WP的用户。

    • 张子凡
      回复
      张子凡 3周前 (05-07)
      回复 @天云复盘 :五一过后官网好像恢复了,但是又是访问还是会出问题。