WordPress插件兼容PHP7.x需要注意和修改的问题

张子凡 WordPress 4个月前 (12-20) 阅读(2167) 评论(4)

程序的不断更新迭代中,不知不觉才发现自己已经开始落后了,最近三个小伙伴一起开始了一个三年之约,所以都购置了新的云服务器,开始了我们各种的计划,那么紧接而来的就是配置服务器环境,这一次依然力求极致,所以在PHP版本上面选择了PHP7.x,虽然网站还在接入服务商备案审核中,但是已经来不及测试了一下WordPress。

WordPress插件兼容PHP7.x需要注意和修改的问题

首先必须值得肯定的是,WordPress程序本身是100%兼容支持PHP7.x的,而在WordPress站点中出现错误的往往都是你的插件或者主题不兼容PHP7.x,其中子凡目前正在使用的一个插件就没有很好的兼容,所以第一时间做了兼容和修复。同时也收集了一些关于WordPress插件兼容php7.x的一些相关问题作为分享。

1. mysql_escape_string() 函数改为 addslashes()

mysql_* 系列函数在php7里全部移除了,所以建议在所有文件里搜索一下 mysql_query, mysql_escape_, mysql_real_eacape 等函数。

2. split() 函数改为 explode()

3. 语法兼容

为函数定义添加默认值,例如:

1
public function options( $value = '' ) {...}

写在最后:子凡目前遇到的情况是第二种,其它两种方法也是参考网上的一些说法,如果还有其它问题后续我们在做更新吧!也欢迎大家留言反馈。

除非注明,否则均为泪雪博客原创文章,转载请以链接形式标明本文地址

本文链接:https://zhangzifan.com/wordpress-plugins-with-php-7x.html

发表评论

  1. 抛丸机网
    1楼
    抛丸机网 4个月前 (12-21)

    博主技术确实厉害

  2. 三五营销
    2楼
    三五营销 4个月前 (12-20)

    偶然来访,受益良多!

    • 张子凡
      回复
      张子凡 4个月前 (12-21)
      回复 @三五营销 :记得常来哈